Download Guide
Purchase Game

Outriders Worldslayer

Vulnerable vs Weakness

By
Ben Chard

Outriders Worldslayer is the new expansion to Outriders that was released on June 30th, 2022. One of the most important features, even more than ever with Worldslayer, is the debate between Vulnerable vs Weakness. This page will give you all the details you need to know about both status effects.

Weakness is an important status effect in Outriders Worldslayer.

What is Vulnerable?

Vulnerable is one of the main status effects in Outriders and understanding how it works properly is vital to getting the most out of your weapons, skills, and mods. When a player or enemy is afflicted with Vulnerable, they will take an additional 15% damage for 10 seconds. This is a nasty status, as depending on the skills you or the enemy may be using, you can really use Vulnerable to up the damage massively.

How to Inflict Vulnerable

There are many ways to deal Vulnerable to enemies, but you’ll have to look around to find it. You can find it as some Class Perks in the original Class Trees such as Exposing Frost for Technomancer’s causing your Freeze to add Vulnerable. You’ll also find plenty of Mods that can add a Vulnerable modifier to your skills or attacks such as the Tier II Mod, Exposing Strike which will cause your Melee kill to inflict Vulnerable on enemies within 10 meters.

What is Weakness?

Weakness is another one of the main status effects in Outriders and like Vulnerable above, you’ll want to understand how it works properly to get the most out of it. When a player or enemy is afflicted with Weakness, they will deal 30% less damage for 6 seconds. Depending on your damage output, this may well be more debilitating than Vulnerable as 30% is a huge number to decrease your damage output by.

How to Inflict Weakness

As with Vulnerable above, there are several ways to deal Weakness to enemies. Using the Trickster as an example, you’ll find some of the Class Perks in the original Class Trees can grant your abilities the chance to deal Weakness such as the Time Rift Active Skill which will inflict Weakness to enemies that are struck by it. Additionally, there are also many mods that will inflict Weakness such as the Tier I Mod, Weakening Zone which will cause enemies entering the Slow Trap skill’s sphere to become afflicted with Weakness.

Time Rift for the Trickster will inflict Weakness without any modifiers.

Should you use Weakness or Vulnerable?

The main question that many people will ask is what is the better of the two Status Effects considering their similarities. A lot of it comes down to your own personal playstyle. If you’re adapt at avoiding taking damage in the first place, then Weakness will have lot less uses for you on the enemy. Vulnerable, on the other hand, is always useful no matter what your playstyle as causing enemies to take more damage is always one of the best status effects you can apply to them.

This becomes less of a question when you find yourself playing with other players. As you can only have one instance of a status on an enemy at a time (inflicting again will refresh, not stack), you’ll want to make sure that you can inflict both Weakness and Vulnerable on your enemies to make life easier. This becomes even more crucial as you head up the Apocalypse Tiers and fight the tougher bosses and Stalwart Elites.

Comments

User profile pic
0
Welcome Guest

Guide Information

  • Publisher
    Square Enix
  • Platforms,
    PC, PS4, PS5, Stadia, XB One, XB X|S
  • Genre
    Adventure, RPG, Third-person shooter
  • Guide Release
    27 June 2022
  • Last Updated
    18 July 2022
    Version History
  • Guide Author

Share this free guide:

This guide for Outriders: Worldslayer includes the following:

Get a Gamer Guides Premium account: